Unity Ninja Unity 3D Forum
To have exclusive access to all downloads, recourses and links within this forum, a free registered account is required. Just a heads up Wink

You are not connected. Please login or register

Unity Ninja Unity 3D Forum » HELP » Help (General) » Help pls, FPS Constructor Problem :(

Help pls, FPS Constructor Problem :(

View previous topic View next topic Go down  Message [Page 1 of 1]

1 Help pls, FPS Constructor Problem :( on Sun Feb 23, 2014 11:48 am


Member [Lv. 1]
Member [Lv. 1]
When i placed FALDrop on my table, and when i started game, i get error, it writes:

UnassignedReferenceException: The variable weapon of 'SelectableWeapon' has not been assigned.
You probably need to assign the weapon variable of the SelectableWeapon script in the inspector.
UnityEngine.GameObject.GetComponent (System.String type) (at C:/BuildAgent/work/d3d49558e4d408f4/artifacts/EditorGenerated/UnityEngineGameObject.cs:35)
SelectableWeapon.Start () (at Assets/Plugins/FPS Constructor V1/ScriptsDB/WeaponScripts/SelectableWeapon.js:20)

Any help pls?  Question 

View user profile

2 Re: Help pls, FPS Constructor Problem :( on Sun Feb 23, 2014 7:23 pm

Hmm, well i've never really used FPS constructor myself, but from the error that I'm reading, it seems as though a variable is not defined. I recommend you click on the 'SelectableWeapon' Script, then if there is a variable that is missing, that is probably called weapon, assign the variable with the FALdrop.

View user profile http://www.youtube.com/user/misterninjaboy

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum