Unity Ninja Unity 3D Forum
To have exclusive access to all downloads, recourses and links within this forum, a free registered account is required. Just a heads up Wink

You are not connected. Please login or register

Unity Ninja Unity 3D Forum » FREE Project Downloads & Recources » Scripts » animation not playing (AnimationSetup)

animation not playing (AnimationSetup)

View previous topic View next topic Go down  Message [Page 1 of 1]

1 animation not playing (AnimationSetup) on Sat Oct 04, 2014 1:58 am

biokid21


Member [Lv. 2]
Member [Lv. 2]
I did exactly as MisterNinjaBoy said in the special ep for fps tut...but it dose not work for me...here is what i did i made the animation and named it walk then i put the script and the animation in the gun.Please Help Me Thanks Smile

View user profile

2 Re: animation not playing (AnimationSetup) on Sat Oct 04, 2014 1:18 pm

DeveloperLuke


Moderator
Moderator
Please put this in Help next time.
Wooden

View user profile

3 Re: animation not playing (AnimationSetup) on Sat Oct 04, 2014 2:10 pm

FPS assault


Member [Lv. 3]
Member [Lv. 3]

I think I know what you did wrong.Select your game object that you want to animate,go to the component tab,then misicellaneous,and click animation.Then you can animate your game object.

View user profile http://truefpscombat.wix.com/fpsassalt

4 Re: animation not playing (AnimationSetup) on Sat Oct 04, 2014 3:55 pm

biokid21


Member [Lv. 2]
Member [Lv. 2]
FPS assault wrote:
I think I know what you did wrong.Select your game object that you want to animate,go to the component tab,then misicellaneous,and click animation.Then you can animate your game object.

i did that but when i do the animation does not start...heres the script:

function Update()
{
if(Input.GetKeyDown("w"))
{
animation.Play("walk", PlayMode.StopAll);
}
}

View user profile

5 Re: animation not playing (AnimationSetup) on Sat Oct 04, 2014 5:06 pm

FPS assault


Member [Lv. 3]
Member [Lv. 3]
Hmmm try this.
Code:
var AnimationClip : AnimationClip ;
function Update() {

 if (Input.GetKeyDown (KeyCode.W))
{
    animation.Play();
 
}

}

View user profile http://truefpscombat.wix.com/fpsassalt

6 Re: animation not playing (AnimationSetup) on Mon Oct 06, 2014 6:25 pm

biokid21


Member [Lv. 2]
Member [Lv. 2]
FPS assault wrote:Hmmm try this.
Code:
var AnimationClip : AnimationClip ;
function Update() {

 if (Input.GetKeyDown (KeyCode.W))
{
    animation.Play();
 
}

}

sorry i dont know where to put it

View user profile

7 Re: animation not playing (AnimationSetup) on Mon Oct 06, 2014 11:35 pm

FPS assault


Member [Lv. 3]
Member [Lv. 3]
Here is a link to my google+,I have you a tutorial for animation I made.If you still cant get it then I dont know what to do.  Wink Good luck     [You must be registered and logged in to see this link.]

View user profile http://truefpscombat.wix.com/fpsassalt

8 Re: animation not playing (AnimationSetup) on Tue Oct 07, 2014 7:27 pm

biokid21


Member [Lv. 2]
Member [Lv. 2]
FPS assault wrote:Here is a link to my google+,I have you a tutorial for animation I made.If you still cant get it then I dont know what to do.  Wink Good luck     [You must be registered and logged in to see this link.]

Thanks Man

View user profile

9 Re: animation not playing (AnimationSetup) on Tue Oct 07, 2014 8:10 pm

FPS assault


Member [Lv. 3]
Member [Lv. 3]
You got it?

View user profile http://truefpscombat.wix.com/fpsassalt

10 Re: animation not playing (AnimationSetup) on Wed Oct 08, 2014 4:32 pm

biokid21


Member [Lv. 2]
Member [Lv. 2]
FPS assault wrote:You got it?

yup it worked Thank You!

View user profile

11 Re: animation not playing (AnimationSetup) on Wed Oct 08, 2014 8:16 pm

FPS assault


Member [Lv. 3]
Member [Lv. 3]
Your very welcome. Smile

View user profile http://truefpscombat.wix.com/fpsassalt

12 Re: animation not playing (AnimationSetup) on Tue Nov 04, 2014 12:55 pm

Pnash600


Member [Lv. 2]
Member [Lv. 2]
I know this forum is a bit old, but I have a different problem. My animation starts without hitting w, and never stops. I restarted the project, and deleted the old one, but just in case it doesn't work again, any tips?

View user profile

13 Re: animation not playing (AnimationSetup) on Wed Nov 05, 2014 7:40 pm

Pnash600 wrote:I know this forum is a bit old, but I have a different problem. My animation starts without hitting w, and never stops. I restarted the project, and deleted the old one, but just in case it doesn't work again, any tips?
This forum is old? I think you mean topic.. Haha as this forum is about to hit it's first 'birthday' this december.. And For trouble with stopping animations, I recommend you skip to my 5th tutorial, where I show how to fix this problem trowards the end of the video, and also include a full source project download, with no problems.

View user profile http://www.youtube.com/user/misterninjaboy

14 Re: animation not playing (AnimationSetup) on Thu Nov 06, 2014 9:01 am

Pnash600


Member [Lv. 2]
Member [Lv. 2]
Okay, thanks for such a quick reply, and one more thing, I wasn't too concerned with that but I will take a look at it, but the aimdownsight script was also giving me an error, something about fpswalker being unknown, I looked it up and could only find one person who had a similar problem but got no answer. I did however find a much more simplified ads script in another aiming tutorial, would it work to just insert that in instead?

View user profile

15 Re: animation not playing (AnimationSetup) on Thu Nov 06, 2014 6:49 pm

Pnash600 wrote:Okay, thanks for such a quick reply, and one more thing, I wasn't too concerned with that but I will take a look at it, but the aimdownsight script was also giving me an error, something about fpswalker being unknown, I looked it up and could only find one person who had a similar problem but got no answer. I did however find a much more simplified ads script in another aiming tutorial, would it work to just insert that in instead?
Yes you can use ur own aiming script, in fact I use a simplified error free aiming script in tut 5 and 6.. So just skip to tut 5 and ignore 4, should solve all your problems.

View user profile http://www.youtube.com/user/misterninjaboy

16 Re: animation not playing (AnimationSetup) on Fri Nov 07, 2014 6:51 am

Pnash600


Member [Lv. 2]
Member [Lv. 2]
Okay, thanks for all your help!

View user profile

17 Re: animation not playing (AnimationSetup) on Sat Mar 07, 2015 7:51 pm

RexiUnity


Member [Lv. 0]
Member [Lv. 0]
hello ..Smile Smile
I have followed your tutorial .. but I have a little problem with the "walking animation".
My animation moves itself without me pressing the "w" and can not stop ..Sad
I use unity 4.5.0
please provide a solution. thank you .... Smile Smile

View user profile

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum